Wadoku.de Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics  
[Register] Register /  [Login] Login 
Wadoku: Downloads und Links > EDICT leider nicht mehr dabei  RSS feed
Forum Index » wadoku.de
Author Message
blauer-fisch



Joined: 30/09/2010 06:53:05
Messages: 12
Offline

Hallo,

wie ich schon seit Beginn des Jahres festgestellt habe, wird kein EDICT Download mehr bereit gestellt. Das finde ich sehr schade, da sich dieses Format bestens fuer mobile Anwendungen eignet.

Gibt es einen Grund fuer die "Vernachlaessigung"?
(Mit Hilfe des Scriptes von GitHub habe ich versucht aus dem XML eine EDICT Datei zu erstellen, jedoch ohne Erfolg.)

Bin sehr auf eine Antwort gespannt, vielen Dank vorab fuer die Unterstutzung.
Dan


[Avatar]

Joined: 24/05/2006 16:58:45
Messages: 1245
Offline

Nunja, das Format ist veraltet.

Das Skript tat bei mir seinen Dienst wie gehabt. was hat bei dir nicht funktioniert?

無知の知
Dan


[Avatar]

Joined: 24/05/2006 16:58:45
Messages: 1245
Offline

Die letzte EDICT(2)-Version ist jetzt zum Download verfügbar.

無知の知
blauer-fisch



Joined: 30/09/2010 06:53:05
Messages: 12
Offline

Vielen Dank fuer die schnelle Antwort und besonders fuer das Erstellen der EDICT Datei!

Als kleine Hintergrund Information: Ich betreibe einen Blog und stelle die wadoku Daten als benutzbares Woerterbuch fuer "Aedict" zur Verfuegung, bin aber nicht der Autor von Aedict. Ich selbst verwende Aedict und verwende das Woerterbuch tatsaechlich jeden Tag.

Da der EDICT Service gestoppt hat, habe ich selbst versucht ein Format zu erstellen. Ich verwende Linux und dachte, mit der Kommandzeile wird das schon gehen, erhalte jedoch nur Fehler:

./xslttransform.pl xsl/entry_export_edict.xsl wadoku.xml > outputfile
Can't locate XML/LibXSLT.pm in @INC (you may need to install the XML::LibXSLT module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at ./xslttransform.pl line 4.
BEGIN failed--compilation aborted at ./xslttransform.pl line 4.


Angeblich fehlt die library "libxslt" - jedoch ist sie installiert und weiss nicht was zu tun ist.
Dan


[Avatar]

Joined: 24/05/2006 16:58:45
Messages: 1245
Offline

Danke für die Fehlermeldung.

Falls du Debian oder Ubuntu nutzt, musst du noch das Paket 'libxml-libxslt-perl' installieren.

sudo apt-get install libxml-libxslt-perl


Bei anderen Linux-Distributionen wird es wohl ein entsprechendes Paket geben.

無知の知
 
Forum Index » wadoku.de
Go to: