Wadoku.de Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics  
[Register] Register /  [Login] Login 
Kanji-Darstellung am PC  RSS feed
Forum Index » Japanisch auf PC/PDA
Author Message
HW60



Joined: 18/03/2011 14:48:54
Messages: 3
Offline

Ich habe Probleme mit der Darstellung von einigen Kanji, z.B. 直, eingegeben als ちょく oder じき oder なおす. Im Auswahlfeld von Microsoft IME erscheint das Zeichen korrekt wie im Wörterbuch mit einer Umrandung links/unten (rechter Winkel), nach der Auswahl dieses Zeichens verschwindet die Umrandung jedoch wie auch hier zu sehen. Das scheint immer dann vorzukommen, wenn das chinesische 汉字und das japanische 漢字unterschiedlich sind: nach der Auswahl in der IME-Tabelle erscheint die chinesische Darstellung des Zeichens zhí. Die korrekte japanische Darstellung kann ich am Windows7-PC nicht herstellen (das gilt auch für das Auswahlfeld unter www.wadoku.de). Weiß jemand Rat?
FreakRob


[Avatar]

Joined: 26/10/2006 20:33:37
Messages: 181
Offline

Hallo und ein herzliches Willkommen im Wadoku-Forum allerseits.

Du gibst recht wenig Informationen. Zuallererst einmal möchte ich feststellen, dass ich weiß, worin Dein Problem besteht und Dich verstanden habe. Das ist auf die Han-Vereinheitlichung des Unicode-Standards zurückzuführen. Wie Du richtig bemerkt hast, gibt es 漢字, die im Japanischen und Chinesischen identisch aussehen. Diese werden bei Dir "fehlerfrei" dargestellt. In Anführungszeichen, da es keine Fehler im klassischen Sinne sind, sondern das sogar so gewollt ist.

Nun hast Du uns nicht gesagt, wo Dein Problem eigentlich auftritt. Dein Browser scheint nicht das Hauptproblem zu sein, denn Du bemerkst nur "wie auch hier zu sehen". Du willst also nehme ich mal an, das ganze in einem Textverarbeitungsprogramm verwenden, z.B. Microsoft Word, Open Office etc. Du hast uns auch nicht gesagt, welche Version des Betriebssystem Windows Du verwendest.

Wie dem auch sei. Dein Problem rührt daher, dass Du zum Anzeigen des Zeichens den falschen Font verwendest. Für japanische Zeichen musst Du einen japanischen Font nehmen, für chinesische Zeichen einen chinesischen.

Was geschieht ist folgendes: Das IME-Pad zeigt standardmäßig in einem japanischen Font an (MS Mincho oder MS Gothic). Was aber am Ende eingegeben wird, ist bloß das (ambige) Zeichen, welches dann im darunter liegenden Font dargestellt wird. In Applikationen wie Word 2007 wird tatsächlicherweise ein Font verwendet, der zur Eingabemethode passt (unabhängig davon, welchen Font Du vorher ausgewählt hattest). Im Webbrowser Firefox wird die Anzeige über die Font-Einstellungen je nach erkannter Sprache getätigt.

Kurzum, Du musst bei Firefox und Co. die richtigen Font-Einstellungen treffen für japanische Texte. Für Textverarbeitungsprogramme musst Du auch den Anzeigefont ändern. Dann geht's und Du solltest das gewünschte Zeichen sehen. Sobald Du uns sagst, welchen Browser und welche Textverarbeitung etc. Du verwendest, lässt sich noch eine genauere Abfolge zur erfolgreichen Konfiguration beschreiben.

So, ich hoffe ich konnte Dir erstmal im Ansatz erklären, was schief läuft und warum. Anbei habe ich noch eine Testdatei im HTML-Format angehangen. Mit der kannst Du überprüfen, ob Dein Browser generell Font-Einstellungen für Japanisch und Chinesisch richtig eingestellt hat, jedoch u.U. Chinesisch bevorzugt, wenn keine Informationen über die Textsprache vorliegen. Die 漢字 「直」 sind jeweils mit der richtigen Sprache getaggt. Anbei auch die Ausgabe meines Webbrowsers. Bemerke, dass insgesamt vier verschiedene Fonts verwendet werden: Times New Roman für lateinischen Text, MS PGothic für Japanisch, SimSun für Chinesisch vereinfacht und MingLiu für Chinesisch traditionell.

cYa,

FreakRob
 Filename  Testdatei.html [Disk] Download
 Description  HTML-Testdatei für Webbrowser
 Filesize   189 bytes
 Downloaded:  1204 time(s)

[Thumb - Testdatei.png]

HW60



Joined: 18/03/2011 14:48:54
Messages: 3
Offline

Das ist ja sehr professionell hier im Forum: kaum stellt man eine kurze Frage, schon erhält man eine ausführlichen Bericht als Antwort, der alle Probleme löst! Dafür erst einmal herzlich Danke!

Ich nutze Windows 7 (64) und MS Office 2007, daneben habe ich die Browser Firefox, Chrome und den Internet-Explorer von MS installiert, nutze aber in der Regel Chrome. Zuerst aufgefallen ist mir das Problem bei Pleco, einer PDA-Software für chinesische Wörterbücher und Flashcards - ich lerne chinesische Vokabeln mit Pleco (www.pleco.com). Mit Hilfe einer japanischen Eingabe-Software für Windows Mobile von http://www.ookii.org/software/japaneseinput/font.aspx kann ich in Pleco auch Hiragana und Katakana eingeben und damit auch japanische Vokabeln lernen (auf einem htc Touch HD mit Windows Mobile 6.5). Bei der Eingabe von 直 (als japanische Vokabel) ist mir dann das Problem das erste Mal aufgefallen.

Nach Deinen Informationen scheint das Problem in Pleco unlösbar zu sein, denn dort habe ich nur einen Font, und der ist chinesisch; ich kann zwar das richtige japanische Kanji per HWR eingeben und es wird auch richtig erkannt, aber es wird mit dem chinesischen Font dargestellt - soweit habe ich die Ausführungen verstanden.

Nach einem Blick ins Kanji-Lexikon wollte ich prüfen, was wadoku.de in diesem Fall tut, und habe denselben Fehler bekommen. Das lag aber, wie ich jetzt dank Deiner Hinweise weiß, nicht an wadoku, sondern an Chrome, der offenbar nicht weiß, dass er nach dem Umschalten der Tastatur auf "Japanisch" auch einen japanischen Font verwenden sollte. Ich habe Deine Testdatei.html in Chrome geöffnet, und sie wird automatisch mit einem chinesischen Font, also "falsch" dargestellt. Das gleiche gilt auch für den Internet Explorer. Firefox stellt die Zeichen mit einem japanischen Font richtig dar: Wenn ich in Firefox auf wadoku.de das japanische 直 eingebe, wird es mit einem japanischen Font dargestellt. Gebe ich dort das chinesische 直 ein, wird ebenfalls ein japanischer Font verwendet. Bei Chrome ist es umgekehrt - es wird immer ein chinesischer Font verwendet.

In Office 2007 wird der Font automatisch auf MS Mincho umgestellt, wenn die Tastatur auf japanisch umgestellt wird - das habe ich aber gerade erst getestet, weil ich bisher in Office gar kein Problem erkannt hatte. Dort läuft offenbar alles wie gewollt.

Fazit: ich habe jetzt nur noch zwei Fragen: 1. kann ich Chrome und Firefox so einstellen, dass der Browser den zur Tastatur passenden Font wählt? 2. Gibt es einen Font, in dem beide Zeichen, 直 (japanisch) und 直 (chinesisch), vorkommen (das wäre die Lösung, die ich als Laie eigentlich automatisch erwartet hätte)?
Dan


[Avatar]

Joined: 24/05/2006 16:58:45
Messages: 1263
Offline

<html>
<body>
Japanisch: <span lang="ja-Hani">直</span>.
Chinesisch (simpl.): <span lang="zh-Hans">直</span>.
Chinesisch (trad.): <span lang="zh-Hant">直</span>.
</body>
</html>

Wie in dem Beispiel von FreakRob zu sehen, muss, um eine differenzierte und ggf. korrekte Darstellung zu erhalten, die Sprache explizit angegeben werden. Leider unterstützen noch nicht alle Browser diesen Mechanismus hinreichend. Firefox tut es, Chrome/Safari noch nicht. Der Hintergrund ist einfach der, dass im Beispiel das 直 nur einen Codepoint hat, und nicht wie vielleicht erwartet, für jede Variante einen eigenen Codepoint. Es obliegt also dem System, zu entscheiden, wie es dargestellt werden soll, japanisch, traditionell chinesisch oder vereinfacht chinesisch.

Im Wadoku wird dieser Mechanismus weitgehend verwendet. So dass, wenn der Browser es unterstützt und ein entsprechender Zeichensatz im System installiert ist, auch z.B. auf einem chinesischen System, eine korrekte Darstellung erfolgen sollte.

無知の知
HW60



Joined: 18/03/2011 14:48:54
Messages: 3
Offline

Danke - jetzt ist mir alles klar. Einen schon etwas älteren Artikel zu dem Thema habe ich unter http://tclab.kaist.ac.kr/~otfried/Mule/unihan.html gefunden.
 
Forum Index » Japanisch auf PC/PDA
Go to: